Postfix と MySQL を連携させる

MySQL の設定をする

mysql> delete from mysql.user where user = '';
Query OK, 2 rows affected (0.00 sec)

mysql> create database postfix;
Query OK, 1 row affected (0.00 sec)

mysql> create user 'postfix'@'localhost' identified by '9wis8aus';
Query OK, 0 rows affected (0.00 sec)

mysql> grant all privileges on postfix.* to postfix@localhost;
Query OK, 0 rows affected (0.00 sec)

mysql> 

mysqld を初めて起動するときの設定

MySQL を起動してユーザーを作成します。

[root@jjs_vps_01 ~]# chkconfig mysqld on
[root@jjs_vps_01 ~]# service mysqld start
Initializing MySQL database:  WARNING: The host 'jjs_vps_01' could not be looked up with resolveip.
This probably means that your libc libraries are not 100 % compatible
with this binary MySQL version. The MySQL daemon, mysqld, should work
normally with the exception that host name resolving will not work.
This means that you should use IP addresses instead of hostnames
when specifying MySQL privileges !
Installing MySQL system tables...
OK
Filling help tables...
OK

To start mysqld at boot time you have to copy
support-files/mysql.server to the right place for your system

PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
To do so, start the server, then issue the following commands:

/usr/bin/mysqladmin -u root password 'new-password'
/usr/bin/mysqladmin -u root -h jjs_vps_01 password 'new-password'

Alternatively you can run:
/usr/bin/mysql_secure_installation

which will also give you the option of removing the test
databases and anonymous user created by default.  This is
strongly recommended for production servers.

See the manual for more instructions.

You can start the MySQL daemon with:
cd /usr ; /usr/bin/mysqld_safe &

You can test the MySQL daemon with mysql-test-run.pl
cd /usr/mysql-test ; perl mysql-test-run.pl

Please report any problems with the /usr/bin/mysqlbug script!

                                                           [  OK  ]
Starting mysqld:                                           [  OK  ]
[root@jjs_vps_01 ~]# mysqladmin -u root password '********'
[root@jjs_vps_01 ~]# mysql -u root -p 
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 4
Server version: 5.1.73 Source distribution

Copyright (c) 2000, 2013, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> create user mysql@localhost identified by '********'
    -> ;
Query OK, 0 rows affected (0.00 sec)

mysql> select user, host from mysql.user;
+-------+--------------+
| user  | host         |
+-------+--------------+
| mysql | %            |
| root  | 127.0.0.1    |
|       | jjs\_vps\_01 |
| root  | jjs\_vps\_01 |
|       | localhost    |
| mysql | localhost    |
| root  | localhost    |
+-------+--------------+
7 rows in set (0.00 sec)

mysql> 

CentOS 6.6 から CentOS 7.0 へアップグレードする方法

会社で申し込んだVPSで CentOS 6.6 のディスクイメージしか用意していないので、運用状態のまま Cent OS 7.0 にアップグレードできないかやってみます。

失敗してぶっ壊れても、もう一度ディスクイメージをインストールしなおせば良いのでVPSは楽ちんです。

[root@jjss_vps_01 ~]# cat /etc/redhat-release
CentOS release 6.6 (Final)
[root@jjss_vps_01 ~]# yum -y update
読み込んだプラグイン:downloadonly, fastestmirror
更新処理の設定をしています
Loading mirror speeds from cached hostfile
* base: ftp.tsukuba.wide.ad.jp
* extras: ftp.tsukuba.wide.ad.jp
* updates: ftp.tsukuba.wide.ad.jp
更新と設定されたパッケージがありません。
[root@jjss_vps_01 ~]# yum -y install openscap pcre-devel libxml2-devel libxslt-devel m2crypto python-simplejson mod_wsgi
読み込んだプラグイン:downloadonly, fastestmirror
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
* base: ftp.tsukuba.wide.ad.jp
* extras: ftp.tsukuba.wide.ad.jp
* updates: ftp.tsukuba.wide.ad.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package libxml2-devel.x86_64 0:2.7.6-17.el6_6.1 will be インストール
--> 依存性の処理をしています: zlib-devel のパッケージ: libxml2-devel-2.7.6-17.el6_6.1.x86_64
---> Package libxslt-devel.x86_64 0:1.1.26-2.el6_3.1 will be インストール
--> 依存性の処理をしています: libxslt = 1.1.26-2.el6_3.1 のパッケージ: libxslt-devel-1.1.26-2.el6_3.1.x86_64
--> 依存性の処理をしています: libgcrypt-devel のパッケージ: libxslt-devel-1.1.26-2.el6_3.1.x86_64
--> 依存性の処理をしています: libxslt.so.1()(64bit) のパッケージ: libxslt-devel-1.1.26-2.el6_3.1.x86_64
--> 依存性の処理をしています: libexslt.so.0()(64bit) のパッケージ: libxslt-devel-1.1.26-2.el6_3.1.x86_64
---> Package m2crypto.x86_64 0:0.20.2-9.el6 will be インストール
---> Package mod_wsgi.x86_64 0:3.2-7.el6 will be インストール
---> Package openscap.x86_64 0:1.0.8-1.0.1.el6.centos.1 will be インストール
---> Package pcre-devel.x86_64 0:7.8-6.el6 will be インストール
---> Package python-simplejson.x86_64 0:2.0.9-3.1.el6 will be インストール
--> トランザクションの確認を実行しています。
---> Package libgcrypt-devel.x86_64 0:1.4.5-11.el6_4 will be インストール
--> 依存性の処理をしています: libgpg-error-devel のパッケージ: libgcrypt-devel-1.4.5-11.el6_4.x86_64
---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be インストール
---> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be インストール
--> トランザクションの確認を実行しています。
---> Package libgpg-error-devel.x86_64 0:1.7-4.el6 will be インストール
--> 依存性解決を終了しました。
依存性を解決しました
========================================================================================================================
パッケージ                      アーキテクチャ      バージョン                              リポジトリー          容量
========================================================================================================================
インストールしています:
libxml2-devel                   x86_64              2.7.6-17.el6_6.1                        updates              1.1 M
libxslt-devel                   x86_64              1.1.26-2.el6_3.1                        base                 561 k
m2crypto                        x86_64              0.20.2-9.el6                            base                 471 k
mod_wsgi                        x86_64              3.2-7.el6                               base                  66 k
openscap                        x86_64              1.0.8-1.0.1.el6.centos.1                base                 2.9 M
pcre-devel                      x86_64              7.8-6.el6                               base                 318 k
python-simplejson               x86_64              2.0.9-3.1.el6                           base                 126 k
依存性関連でのインストールをします。:
libgcrypt-devel                 x86_64              1.4.5-11.el6_4                          base                 118 k
libgpg-error-devel              x86_64              1.7-4.el6                               base                  14 k
libxslt                         x86_64              1.1.26-2.el6_3.1                        base                 452 k
zlib-devel                      x86_64              1.2.3-29.el6                            base                  44 k
トランザクションの要約
========================================================================================================================
インストール        11 パッケージ
総ダウンロード容量: 6.1 M
インストール済み容量: 60 M
パッケージをダウンロードしています:
(1/11): libgcrypt-devel-1.4.5-11.el6_4.x86_64.rpm                                                | 118 kB     00:00
(2/11): libgpg-error-devel-1.7-4.el6.x86_64.rpm                                                  |  14 kB     00:00
(3/11): libxml2-devel-2.7.6-17.el6_6.1.x86_64.rpm                                                | 1.1 MB     00:00
(4/11): libxslt-1.1.26-2.el6_3.1.x86_64.rpm                                                      | 452 kB     00:00
(5/11): libxslt-devel-1.1.26-2.el6_3.1.x86_64.rpm                                                | 561 kB     00:00
(6/11): m2crypto-0.20.2-9.el6.x86_64.rpm                                                         | 471 kB     00:00
(7/11): mod_wsgi-3.2-7.el6.x86_64.rpm                                                            |  66 kB     00:00
(8/11): openscap-1.0.8-1.0.1.el6.centos.1.x86_64.rpm                                             | 2.9 MB     00:00
(9/11): pcre-devel-7.8-6.el6.x86_64.rpm                                                          | 318 kB     00:00
(10/11): python-simplejson-2.0.9-3.1.el6.x86_64.rpm                                              | 126 kB     00:00
(11/11): zlib-devel-1.2.3-29.el6.x86_64.rpm                                                      |  44 kB     00:00
------------------------------------------------------------------------------------------------------------------------
合計                                                                                     10 MB/s | 6.1 MB     00:00
rpm_check_debug を実行しています
トランザクションのテストを実行しています
トランザクションのテストを成功しました
トランザクションを実行しています
インストールしています  : libxslt-1.1.26-2.el6_3.1.x86_64                                                        1/11
インストールしています  : zlib-devel-1.2.3-29.el6.x86_64                                                         2/11
インストールしています  : libxml2-devel-2.7.6-17.el6_6.1.x86_64                                                  3/11
インストールしています  : libgpg-error-devel-1.7-4.el6.x86_64                                                    4/11
インストールしています  : libgcrypt-devel-1.4.5-11.el6_4.x86_64                                                  5/11
インストールしています  : libxslt-devel-1.1.26-2.el6_3.1.x86_64                                                  6/11
インストールしています  : openscap-1.0.8-1.0.1.el6.centos.1.x86_64                                               7/11
インストールしています  : mod_wsgi-3.2-7.el6.x86_64                                                              8/11
インストールしています  : m2crypto-0.20.2-9.el6.x86_64                                                           9/11
インストールしています  : python-simplejson-2.0.9-3.1.el6.x86_64                                                10/11
インストールしています  : pcre-devel-7.8-6.el6.x86_64                                                           11/11
Verifying               : libgcrypt-devel-1.4.5-11.el6_4.x86_64                                                  1/11
Verifying               : pcre-devel-7.8-6.el6.x86_64                                                            2/11
Verifying               : libgpg-error-devel-1.7-4.el6.x86_64                                                    3/11
Verifying               : libxml2-devel-2.7.6-17.el6_6.1.x86_64                                                  4/11
Verifying               : python-simplejson-2.0.9-3.1.el6.x86_64                                                 5/11
Verifying               : m2crypto-0.20.2-9.el6.x86_64                                                           6/11
Verifying               : openscap-1.0.8-1.0.1.el6.centos.1.x86_64                                               7/11
Verifying               : libxslt-devel-1.1.26-2.el6_3.1.x86_64                                                  8/11
Verifying               : zlib-devel-1.2.3-29.el6.x86_64                                                         9/11
Verifying               : libxslt-1.1.26-2.el6_3.1.x86_64                                                       10/11
Verifying               : mod_wsgi-3.2-7.el6.x86_64                                                             11/11
インストール:
libxml2-devel.x86_64 0:2.7.6-17.el6_6.1   libxslt-devel.x86_64 0:1.1.26-2.el6_3.1     m2crypto.x86_64 0:0.20.2-9.el6
mod_wsgi.x86_64 0:3.2-7.el6               openscap.x86_64 0:1.0.8-1.0.1.el6.centos.1  pcre-devel.x86_64 0:7.8-6.el6
python-simplejson.x86_64 0:2.0.9-3.1.el6
依存性関連をインストールしました:
libgcrypt-devel.x86_64 0:1.4.5-11.el6_4   libgpg-error-devel.x86_64 0:1.7-4.el6   libxslt.x86_64 0:1.1.26-2.el6_3.1
zlib-devel.x86_64 0:1.2.3-29.el6
完了しました!
[root@jjss_vps_01 ~]# rpm -ihv http://dev.centos.org/centos/6/upg/x86_64/Packages/preupgrade-assistant-1.0.2-33.0.3.el6.centos.x86_64.rpm
http://dev.centos.org/centos/6/upg/x86_64/Packages/preupgrade-assistant-1.0.2-33.0.3.el6.centos.x86_64.rpm を取得中
準備中...                ########################################### [100%]
1:preupgrade-assistant   ########################################### [100%]
[root@jjss_vps_01 ~]# rpm -ihv http://dev.centos.org/centos/6/upg/x86_64/Packages/preupgrade-assistant-contents-0.5.13-1.0.5.el6.centos.noarch.rpm
http://dev.centos.org/centos/6/upg/x86_64/Packages/preupgrade-assistant-contents-0.5.13-1.0.5.el6.centos.noarch.rpm を取得中
準備中...                ########################################### [100%]
1:preupgrade-assistant-co########################################### [100%]
[root@jjss_vps_01 ~]# rpm -ihv http://dev.centos.org/centos/6/upg/x86_64/Packages/preupgrade-assistant-ui-1.0.2-33.0.3.el6.centos.x86_64.rpm
http://dev.centos.org/centos/6/upg/x86_64/Packages/preupgrade-assistant-ui-1.0.2-33.0.3.el6.centos.x86_64.rpm を取得中
準備中...                ########################################### [100%]
1:preupgrade-assistant-ui########################################### [100%]
[root@jjss_vps_01 ~]# rpm -ihv http://dev.centos.org/centos/6/upg/x86_64/Packages/redhat-upgrade-tool-0.7.22-3.el6.centos.noarch.rpm
http://dev.centos.org/centos/6/upg/x86_64/Packages/redhat-upgrade-tool-0.7.22-3.el6.centos.noarch.rpm を取得中
準備中...                ########################################### [100%]
1:redhat-upgrade-tool    ########################################### [100%]
[root@jjss_vps_01 ~]#
rpm --import http://ftp.plusline.de/centos/7.0.1406/os/x86_64/RPM-GPG-KEY-CentOS-7
[root@jjss_vps_01 ~]# preupg -s CentOS6_7
Preupg tool doesn't do the actual upgrade.
Please ensure you have backed up your system and/or data in the event of a failed upgrade
that would require a full re-install of the system from installation media.
Do you want to continue? y/n
y
Gathering logs used by preupgrade assistant:
All installed packages : 01/11 ...finished (time 00:00s)
All changed files      : 02/11 ...finished (time 02:55s)
Changed config files   : 03/11 ...finished (time 00:00s)
All users              : 04/11 ...finished (time 00:00s)
All groups             : 05/11 ...finished (time 00:00s)
Service statuses       : 06/11 ...finished (time 00:00s)
All installed files    : 07/11 ...finished (time 00:01s)
All local files        : 08/11 ...finished (time 00:07s)
All executable files   : 09/11 ...finished (time 00:00s)
RedHat signed packages : 10/11 ...finished (time 00:00s)
CentOS signed packages : 11/11 ...finished (time 00:00s)
Assessment of the system, running checks / SCE scripts:
001/095 ...done    (Configuration Files to Review)
002/095 ...done    (File Lists for Manual Migration)
003/095 ...done    (Bacula Backup Software)
004/095 ...done    (MySQL configuration)
005/095 ...done    (Migration of the MySQL data stack)
006/095 ...done    (General changes in default MySQL implementation)
007/095 ...done    (PostgreSQL upgrade content)
008/095 ...done    (GNOME Desktop Environment underwent several design modifications in CentOS 7 release)
009/095 ...done    (KDE Desktop Environment underwent several design modifications in CentOS 7 release)
010/095 ...done    (several graphic drivers not supported in CentOS 7)
011/095 ...done    (several input drivers not supported in CentOS 7)
012/095 ...done    (several kernel networking drivers not available in CentOS 7)
013/095 ...done    (several kernel storage drivers not available in CentOS 7)
014/095 ...done    (Names, Options and Output Format Changes in arptables)
015/095 ...done    (BIND9 running in a chroot environment check.)
016/095 ...done    (BIND9 configuration compatibility check)
017/095 ...done    (Move dhcpd/dhcprelay arguments from /etc/sysconfig/* to *.service files)
018/095 ...done    (DNSMASQ configuration compatibility check)
019/095 ...done    (Dovecot configuration compatibility check)
020/095 ...done    (Compatibility Between iptables and ip6tables)
021/095 ...done    (Net-SNMP check)
022/095 ...done    (Squid configuration compatibility check)
023/095 ...done    (Reusable Configuration Files)
024/095 ...done    (VCS repositories)
025/095 ...done    (Added and extended options for BIND9 configuration)
026/095 ...done    (Added options in DNSMASQ configuration)
027/095 ...done    (Packages not signed by CentOS)
028/095 ...done    (Obsoleted rpms)
029/095 ...done    (w3m not available in CentOS 7)
030/095 ...done    (report incompatibilities between CentOS 6 and 7 in qemu-guest-agent package)
031/095 ...done    (Removed options in coreutils binaries)
032/095 ...done    (Removed options in gawk binaries)
033/095 ...done    (Removed options in netstat binary)
034/095 ...done    (Removed options in quota tools)
035/095 ...done    (Removed rpms)
036/095 ...done    (Replaced rpms)
037/095 ...done    (GMP library incompatibilities)
038/095 ...done    (package downgrades)
039/095 ...done    (restore custom selinux configuration)
040/095 ...done    (General)
041/095 ...done    (samba shared directories selinux)
042/095 ...done    (CUPS Browsing/BrowsePoll configuration)
043/095 ...done    (CVS Package Split)
044/095 ...done    (FreeRADIUS Upgrade Verification)
045/095 ...done    (httpd configuration compatibility check)
046/095 ...done    (bind-dyndb-ldap)
047/095 ...done    (Identity Management Server compatibility check)
048/095 ...done    (IPA Server CA Verification)
049/095 ...done    (NTP configuration)
050/095 ...done    (Information on time-sync.target)
051/095 ...done    (OpenLDAP /etc/sysconfig and data compatibility)
052/095 ...done    (OpenSSH sshd_config migration content)
053/095 ...done    (OpenSSH sysconfig migration content)
054/095 ...done    (Configuration for quota_nld service)
055/095 ...done    (Disk quota netlink message daemon moved into quota-nld package)
056/095 ...done    (SSSD compatibility check)
057/095 ...done    (Luks encrypted partition)
058/095 ...done    (Clvmd and cmirrord daemon management.)
059/095 ...done    (State of LVM2 services.)
060/095 ...done    (device-mapper-multipath configuration compatibility check)
061/095 ...done    (Removal of scsi-target-utils)
062/095 ...done    (Configuration for warnquota tool)
063/095 ...done    (Disk quota tool warnquota moved into quota-warnquota package)
064/095 ...done    (Architecture Support)
065/095 ...done    (Binary rebuilds)
066/095 ...done    (Debuginfo packages)
067/095 ...done    (Cluster and High Availablility)
068/095 ...done    (fix krb5kdc config file)
069/095 ...done    (File Systems, Partitions and Mounts Configuration Review)
070/095 ...done    (Read Only FHS directories)
071/095 ...done    (Sonamebumped libs)
072/095 ...done    (SonameKept Reusable Dynamic Libraries)
073/095 ...done    (Removed .so libs)
074/095 ...done    (In-place Upgrade Requirements for the /usr/ Directory)
075/095 ...done    (CA certificate bundles modified)
076/095 ...done    (Developer Tool Set packages)
077/095 ...done    (Hyper-V)
078/095 ...done    (Content for enabling and disabling services based on CentOS 6 system)
079/095 ...done    (Check for ethernet interface naming)
080/095 ...done    (User modification in /etc/rc.local and /etc/rc.d/rc.local)
081/095 ...done    (cgroups configuration compatibility check)
082/095 ...done    (Plugable authentication modules (PAM))
083/095 ...done    (Foreign Perl modules)
084/095 ...done    (Python 2.7.5)
085/095 ...done    (Ruby 2.0.0)
086/095 ...done    (SCL collections)
087/095 ...done    (System kickstart)
088/095 ...done    (YUM)
089/095 ...done    (Check for usage of dangerous range of UID/GIDs)
090/095 ...done    (Incorrect usage of reserved UID/GIDs)
091/095 ...done    (NIS ypbind config files back-up)
092/095 ...done    (NIS Makefile back-up)
093/095 ...done    (NIS server maps check)
094/095 ...done    (NIS server MAXUID and MAXGID limits check)
095/095 ...done    (NIS server config file back-up)
Assessment finished (time 04:08s)
Result table with checks and their results for main contents:
---------------------------------------------------------------------------------------------------------------
|Bacula Backup Software                                                                    |notapplicable     |
|GNOME Desktop Environment underwent several design modifications in CentOS 7 release      |notapplicable     |
|KDE Desktop Environment underwent several design modifications in CentOS 7 release        |notapplicable     |
|several graphic drivers not supported in CentOS 7                                         |notapplicable     |
|several input drivers not supported in CentOS 7                                           |notapplicable     |
|Names, Options and Output Format Changes in arptables                                     |notapplicable     |
|BIND9 running in a chroot environment check.                                              |notapplicable     |
|Move dhcpd/dhcprelay arguments from /etc/sysconfig/* to *.service files                   |notapplicable     |
|DNSMASQ configuration compatibility check                                                 |notapplicable     |
|Dovecot configuration compatibility check                                                 |notapplicable     |
|Net-SNMP check                                                                            |notapplicable     |
|Squid configuration compatibility check                                                   |notapplicable     |
|Added options in DNSMASQ configuration                                                    |notapplicable     |
|w3m not available in CentOS 7                                                             |notapplicable     |
|report incompatibilities between CentOS 6 and 7 in qemu-guest-agent package               |notapplicable     |
|restore custom selinux configuration                                                      |notapplicable     |
|samba shared directories selinux                                                          |notapplicable     |
|CUPS Browsing/BrowsePoll configuration                                                    |notapplicable     |
|CVS Package Split                                                                         |notapplicable     |
|FreeRADIUS Upgrade Verification                                                           |notapplicable     |
|bind-dyndb-ldap                                                                           |notapplicable     |
|Identity Management Server compatibility check                                            |notapplicable     |
|IPA Server CA Verification                                                                |notapplicable     |
|NTP configuration                                                                         |notapplicable     |
|Information on time-sync.target                                                           |notapplicable     |
|OpenLDAP /etc/sysconfig and data compatibility                                            |notapplicable     |
|SSSD compatibility check                                                                  |notapplicable     |
|Luks encrypted partition                                                                  |notapplicable     |
|Clvmd and cmirrord daemon management.                                                     |notapplicable     |
|State of LVM2 services.                                                                   |notapplicable     |
|device-mapper-multipath configuration compatibility check                                 |notapplicable     |
|Removal of scsi-target-utils                                                              |notapplicable     |
|fix krb5kdc config file                                                                   |notapplicable     |
|cgroups configuration compatibility check                                                 |notapplicable     |
|SCL collections                                                                           |notapplicable     |
|System kickstart                                                                          |notapplicable     |
|NIS ypbind config files back-up                                                           |notapplicable     |
|NIS Makefile back-up                                                                      |notapplicable     |
|NIS server maps check                                                                     |notapplicable     |
|NIS server MAXUID and MAXGID limits check                                                 |notapplicable     |
|NIS server config file back-up                                                            |notapplicable     |
|Migration of the MySQL data stack                                                         |pass              |
|General changes in default MySQL implementation                                           |pass              |
|several kernel networking drivers not available in CentOS 7                               |pass              |
|several kernel storage drivers not available in CentOS 7                                  |pass              |
|Compatibility Between iptables and ip6tables                                              |pass              |
|Reusable Configuration Files                                                              |pass              |
|OpenSSH sshd_config migration content                                                     |pass              |
|Configuration for quota_nld service                                                       |pass              |
|Disk quota netlink message daemon moved into quota-nld package                            |pass              |
|Configuration for warnquota tool                                                          |pass              |
|Architecture Support                                                                      |pass              |
|Debuginfo packages                                                                        |pass              |
|Cluster and High Availablility                                                            |pass              |
|In-place Upgrade Requirements for the /usr/ Directory                                     |pass              |
|CA certificate bundles modified                                                           |pass              |
|Developer Tool Set packages                                                               |pass              |
|Hyper-V                                                                                   |pass              |
|Check for ethernet interface naming                                                       |pass              |
|Plugable authentication modules (PAM)                                                     |pass              |
|Python 2.7.5                                                                              |pass              |
|Ruby 2.0.0                                                                                |pass              |
|Check for usage of dangerous range of UID/GIDs                                            |pass              |
|Incorrect usage of reserved UID/GIDs                                                      |pass              |
|MySQL configuration                                                                       |informational     |
|VCS repositories                                                                          |informational     |
|Added and extended options for BIND9 configuration                                        |informational     |
|Removed options in coreutils binaries                                                     |informational     |
|Removed options in gawk binaries                                                          |informational     |
|Removed options in netstat binary                                                         |informational     |
|Removed options in quota tools                                                            |informational     |
|GMP library incompatibilities                                                             |informational     |
|httpd configuration compatibility check                                                   |informational     |
|Disk quota tool warnquota moved into quota-warnquota package                              |informational     |
|File Systems, Partitions and Mounts Configuration Review                                  |informational     |
|Read Only FHS directories                                                                 |informational     |
|Sonamebumped libs                                                                         |informational     |
|SonameKept Reusable Dynamic Libraries                                                     |informational     |
|Removed .so libs                                                                          |informational     |
|Content for enabling and disabling services based on CentOS 6 system                      |informational     |
|Foreign Perl modules                                                                      |informational     |
|YUM                                                                                       |informational     |
|BIND9 configuration compatibility check                                                   |fixed             |
|Replaced rpms                                                                             |fixed             |
|package downgrades                                                                        |fixed             |
|OpenSSH sysconfig migration content                                                       |fixed             |
|Configuration Files to Review                                                             |needs_inspection  |
|File Lists for Manual Migration                                                           |needs_inspection  |
|PostgreSQL upgrade content                                                                |needs_inspection  |
|Obsoleted rpms                                                                            |needs_inspection  |
|Binary rebuilds                                                                           |needs_inspection  |
|Packages not signed by CentOS                                                             |needs_action      |
|Removed rpms                                                                              |needs_action      |
|General                                                                                   |needs_action      |
|User modification in /etc/rc.local and /etc/rc.d/rc.local                                 |needs_action      |
---------------------------------------------------------------------------------------------------------------
Tarball with results is stored here /root/preupgrade-results/preupg_results-150320150211.tar.gz .
The latest assessment is stored in directory /root/preupgrade .
Summary information:
We found some potential in-place upgrade risks.
Read the file /root/preupgrade/result.html for more details.
Upload results to UI by command:
e.g. preupg -u http://127.0.0.1:8099/submit/ -r /root/preupgrade-results/preupg_results-*.tar.gz .
[root@jjss_vps_01 ~]# redhat-upgrade-tool-cli --network 7.0 --instrepo http://mirror.centos.org/centos/7/os/x86_64/ --force
setting up repos...
No upgrade available for the following repos: base extras updates
.treeinfo                                                               | 1.1 kB     00:00
getting boot images...
setting up update...
verify local files 100% [=====================================================================]
testing upgrade transaction
rpm transaction 100% [========================================================================]
rpm install 100% [============================================================================]
setting up system for upgrade
Finished. Reboot to start upgrade.
[root@jjss_vps_01 ~]# reboot

スクリーンショット 2015-03-20 15.56.01

 

再起動後にアップデートが進んだのだが。

スクリーンショット 2015-03-20 16.00.10

Virtual Console を初期化できずサービスが死亡。